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Export via CADS Revit SCIA Engineer Link

Open Revit-SCIA Transfer.rvt from folder

Link Location & Setup
1. Open the CADS Revit SCIA Engineer link by selecting the CADS tab from the list of panels.

EHG-Q- @ =-FOA B-0F LB-- Au

X m @ ? @ P> Getting Started s CheckList

. . - - &5 Best Practices
Options Consistency Review &~ Show Review & Select @ About

Checks Export  Unexported Import ~ Imported”  (7) Help
CADS Revit Scia Engineer Link

2. Select the Options button X to open the options dialogue box.
Options
3. Verify that the following actions are setup:
a. National Code = IBC
b. Launch SCIA Engineer = No
c. SCIA Engineer Version = Browse depending on install version
d. Export Selected Items Only = Checked

4. Once the actions are setup, it is possible to make modifications to the Options as well.

~
ﬁlﬁ CADS Revit Scia Engineer Link | Y |
Actions Options
=
National Code == |IBC hd 4 Bxport
Intemal Edges with Beams No
Launch Scia Engineer Revit Foundation Slab as Slab
- Revit lsolated Foundati Support
Scia Engineer Version 15.0.93 4 E sloll ouln on as
Export Selected hems Only [] lgnore Load Yes
Export to Scia Engineer :gnore ﬁadb&r;:naﬁons :ec
ignore Member ease es
d CmahiE Ignore Slabs No
lgnore Support Yes
lgnore Walls No
Impaort from Scia Engineer 4 Import
Analysie results Yes
Update 20 Member Openings No
P 4 User Mapping
Material as Unknown Mo
Mapping Tables
| Prefemed Tables | | UserTable | Analysis results
Set "Yes'to import analysis results from Scia Engineer.
[ Section Parameter Mapping ] Requires "Structural Analysis Toolkit' from Autodesk Exchange Apps.

Help

3
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Mapping Tables

The transfer of data between Autodesk Revit and SCIA Engineer is dependent on Mapping Tables. These
mapping tables are used to link the Revit Section Name & Family Name to the corresponding SCIA
Engineer Section and Catalog name.

1. To access the mapping tables, select the Preferred Tables button in the Option dialogue box of the
CADS Revit SCIA Engineer link.

Mapping Tables

[ Preferred Tables ‘ [

User Table ]

2. Inthe Preferred Database, it is possible to arrange the pre-installed databases in order of desired
priority. In addition, it is also possible to change the mapping rules and add user Revit family paths to
the database. For this exercise, set the databases as shown below.

-

Uzer Table
General Section-Imperial
Document-Materals
General-Materials
Metric Sections - US
Belgium Columns
Belgium Beams
Europe Specific Sections
General Section-Metric

ﬂﬁ] Preferred Databases | ==
US-Imperial » | High Priority

m

Wiemw

| Low Priorty

Mapping Rules

Cross Section [Use f not found

7]

Material [Use ¥ not found

7]

[ Source Mapping Rules ]

l Target Mapping Rules l

[ Revit Family Mapping ]

| Revit Family Path |

[ ok | [ cance |

3. The User Table is a listing of items that were either added by the user before running an exchange, or
added by the user during the exchange process. The user table will be discussed in more detail later.



Model Visibility and Filters

This model already includes two separate Revit filters. These filters are set up to break apart the model into
elements that will be transferred using the link and those that will be transferred using the IFC exchange.

iz S

Foundation New...
Steel/Concrete
Edit...
Rename...
Delete

r—1
i
Visibility/

To enable or disable the filters in order to view only a portion of the model, use the s-ne: button and navigate
to the Filters tab. For the link transfer, disable the visibility of the Foundation filter.

{ ™y
Visibility/Graphic Overrides for 3D View: {3D} ﬂ

|

[ Model Categories l Annotation Categories l Analytical Model Categories l Imported Categories | Filters I

s Projection/Surface Cut
Name Visibility = = Halftone
i Lines | Patterns | Transparen... Lines Patterns
Steel/Concrete | | O
Foundation [ ] Override... | Override... Override... Override... Override... “

Export to SCIA Engineer (CADS link)

1. When the visibility is properly set, highlight all the items and select the Review & Export button p_._. zin
the CADS Revit SCIA Engineer Link. Export



4%_

Note: The transfer between Autodesk Revit and SCIA Engineer is based on a properly constructed
analytical model in Revit Structures. All of the information that will be transferred between the two
software’s in gathered from the analytical model in Revit. If no analytical model is set up, then no
information will be exchanged. For more information on the analytical model in Autodesk Revit, as well
as Analytical Model tools, refer to Best Practice PDF found in the link as well as other Autodesk
documentation.

2. After selecting export, the export model preview will appear. It is in this interface that specific items can
be selected/deselected for export

CADS Revit Scia Engineer Link - Model Preview = E=E=]
Revit -
@ 1d Category Section Material Changes Export 0
» 257738 Stuctural Coumns  HSS10XBX3/6 Metz| - Stes| - ASTM AS00 - Grade B - Rectangular and Souare New v
257739 Structural Columns HSS10X8X3/8 Metal - Steel - ASTM A500 - Grade B - Rectangular and Square New E
257740 Structural Columns HSS10X8X3/8 Metal - Steel - ASTM A500 - Grade B - Rectangular and Square New m
257741 Structural Columns HSS10XBX3/8 Metal - Stes - ASTM AS00 - Grade B - Rectangular and Square New 5l
257742 Structural Columns HSS10X8X3/8 Metal - Steel - ASTM AS00 - Grade B - Rectangular and Square New m
257743 Structural Columns HSS10XBX3/8 Metz| - Stes| - ASTM AS00 - Grade B - Rectangular and Souare New v
257744 Structural Columns HSS 10X8X3/8 Metal - Steel - ASTM AS00 - Grade B - Rectangular and Square New E
257745 Structural Columns HSS10X8X3f8 Metal - Steel - ASTM A500 - Grade B - Rectangular and Square: New m
257746 Structural Columns HSS10XBX3/8 Metz| - Stes| - ASTM AS00 - Grade B - Rectangular and Souare New v
257747 Structural Columns HSS10X8X3/8 Metal - Steel - ASTM A500 - Grade B - Rectangular and Square New E
257748 Structural Columns HSS10X8X3/8 Metal - Steel - ASTM A500 - Grade B - Rectangular and Square New m
257749 Structural Columns  HSS10XBX3/8 Metal - Stes - ASTM AS00 - Grade B - Rectangular and Square New 5l
257770 Structural Framing HSS8X4X3f8 Steel ASTM A500, Grade B, Rectanguiar and Square New 4
257771 Structural Framing HSSBY4X3/8 Steel ASTM ASDO, Grade B, Rectangular and Sauare New v
257772 Structural Framing HSSBX4X3f8 Steel ASTM A500, Grade B, Rectanguiar and Square New v
257773 Structural Framing HSS8X4X3/8 Steel ASTM A500, Grade B, Rectanguiar and Square New 4
257774 Structurl Framing H5S8Y443/8 Steel ASTM ASDO, Grade B, Rectangular and Sauare New v
257775 Structural Framing HS58X4X3f8 Steel ASTM A500, Grade B, Rectanguiar and Square New %)
257776 Structural Framing HSSBX4X3/8 Steel ASTM A500, Grade B, Rectangular and Square New 4
257777 Structural Framing HSSBY4X3/8 Steel ASTM ASD0, Grade 8, Rectanguiar and Sauare New 5l
ol £ 4asl ASTIL AeR Dactanuiae and " o b
Zoom to selection
| saebg | | Bgot | | cose |

3. After selecting export, the link will prompt the user to save an .r2s (Revit2SCIA) file. Select any location
and name and click OK.



4. First, the link will read the entire Revit model and separate the items to be exchanged into categories.
Once the read portion is complete, the model will begin to be exported. During the export process, if the
link identifies a Material or Cross Section that is not found in the standard mapping tables then the

following dialogue box will appear.

-

Material Mapping

Revit Material 'Metal - Steel - ASTM A500 - Grade B - Rectangular and Square' for
the National Code 'IBC' is not found!
Do you want to add this material?

| ves || nNo || cancel |

\
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5. Selecting Yes will open the following dialogue box and will allow the user to add the mapping information
for the specified Revit material. Set the mapping as shown below and click OK.

ﬂb Add Material Mapping To User Table [ =]

Material Category :

National Code :

[7] Use as Unknown

Supporting Mapping Database :

Revit Material Name :

Scia Engineer Material Name :

[ Document-Materials v ]

Steel

Metal - Steel - ASTM A500 - Grade B - Rec

1BC

A500 grade B -

ok |

[ Cancel

Complete a similar process for the mapping of the cross section, 3" STD PIPE in the Revit Family, HSS

— Round Structural Tubing setting the mapping as shown below. Both the material and the cross section
mapping will be saved in the User Mapping Table. Once a material/cross section is mapped by the user,
the link will utilize the new mapping for subsequent transfers.

ﬁlﬁ Add Cross Section To User Table

Revit
Famity MName

Section Name :

Famity Role :

Scia Engineer
Catalog Mame :

Section Name :

Catalog Id :

Supporting Mapping Database : | |5 jmperial M

HSS-Hollow Structural Section-1

H556X6X5/16

Frame

FRolled

HS55{Imp)6X6X5/16 R

2

[] Use as Mumerical Cross Section

e —

[] Use as General Cross Section

Ok

] [ Cancel ]




7. When the link has finished the exchange, a list of the mapped cross sections and materials is shown.
Also, shown is the total number of items exported. It is also possible to save a log of the exchange to a
Word file.

T — =

Category Total ftems: Exported Not Exported * "W12X79" is mapped as "W(Imp)12X79" -
y 260 262 + "W10X45"is mapped as "W(mp)10x45"
+"W30X90" is mapped as "W({Imp)30X90"
Structurel Framing 708 76 +"CEXQ" is mapped as "C({Imp)5Xa"
Walls 53 5 « "W16X31" is mapped as "W{Imp)16X31"
Floors. 13 13 +"W1BK35" is mapped as "W(mp)18X35"
« “W12X19"is mapped as "W(Imp)12X19”
Total 1034 1034
+ "HSSBX4X/E" is mapped as "HSS(Imp)BX4X3/E"

+ "W27X84" is mapped as "W(Imp)27X84"
+ "W24X55" is mapped as "W(Imp)24X55”

Summary: I
262 out of 262 Structural Columns exported
706 out of 706 Structural Framing exported
53 out of 53 Walls exported

13 out of 13 Floors exportad

Total items exported 1034 out of 1034

End Time : 01/07/2016 09:28:07

Total Time : 00:01:36.4266417

Export to Scia Engineer is completed!
Please save this Revil model to refain the synchronisation wih the exported Scia Engineer model

=

= It | EY ™
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Export via IFC (Industry Foundation Class)

1. The remaining items in the model (Foundations) will be transferred using the IFC file format. In order to
properly exchange the foundation information, change the Filter in View > Visibility/Graphics so the
Foundation filter is checked on.

Visibility/Graphic Overrides for 3D View: {30} =]
[ Mode! Categories | Annotation Categories | Analytical Model Categories | Imported Categories | Filters |
||
R Projection/Surface Cut
Name Visibility - - Halftone

[l Lines Patterns I Transparen... Lines Patterns

Steel/Concrete O ]

Foundation Override... Override... | Override... | Override... Override... “

2. Once only the foundation elements are shown, select all the elements and navigate to Revit button >
Export > IFC file.

EH@E - Q-2 27O A G- 5E
Creates exchange files and sets options.

D New » CAD Formats
cap|  Creates DWG, DXF, DGM, or SAT files, '
[== open » DWF/DWFx

Creates DWF or DWFx files,

Building Site
Exports an ADSK exchange file,

E Save
g Save As ]
= Export »

Suite
Workflows

FBX
Saves a 30 view as an FBEX file.

Family Types
Exports family types from the current
family to a text [tut) file.

-

®$-@he

IFC
Saves an IFCfile,

3. Select a location, file name and make sure that you are exporting only the “Current View” so that only
the elements that are selected are exported.

4. When the export is complete, Autodesk Revit can be closed.
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Import into SCIA Engineer

Now that the .r2s file and the IFC file have been exported from Revit Structures, the user can import
both and combine them into one file in SCIA Engineer.
Import .r2s file
1. Toimport the .r2s file, navigate to File > Import > Revit file while in SCIA Engineer.
2. Navigate to the location for the saved .r2s file and open it.

3. Once the file is opened, the user has the option to select the code used for the SCIA Engineer file.
Make sure that the code used in Revit Structures matched the code used in SCIA Engineer. If a new
code needs to be added, select the Add button to change the code.

v
Codes in project | = |
l Name l Description |

=BC 18C
Delete Active code Close
X

4. Select Close and the file will be imported. Use the Zoom All button to show the entire model.

Import IFC file

1. Toimport the IFC file into the same SCIA Engineer file, navigate to File > Update > IFC2x3 and select
the saved IFC export from Revit Structures.

2. When the IFC Import Options dialogue appears, modify the setting for the import of the geometry as
follows and click OK.

r N
Ifc Import Options &J

Import entities Geometry
[V 1D members " as members
[V 2D members ¥ as reference model
[V Reinforcement
[V Tendons I Analysis shape only
vV Others I~ Run member recognizer

~Tendons —Material table -
@ asinternal

Choose File... I Edit I

" asfree
Storeys - ~National code
[~ Import storeys == Change...

3. The IFC file will be imported and the Update dialogue window will open. From the update window, the
new entities are identified in Green, while the existing entities are identified in Red. It is now possible to
select the entities that should remain in the update. Uncheck the box for Deleted Entities and click
Accept. Once the changes have been accepted, the dialogue can be closed.

12



‘. Update from another project

@R = f. ks AAAQ UK 2L B[
|| [ change
I i 1

) I

Automatical zoom all selection. CAP NUM SCRL

The model is now updated and aligned with the foundation elements inserted as General Solid
geometry. This geometry can now be dealt with in a variety of different ways. It is first possible to
convert the foundation elements into plate elements using the BIM toolbox and the Convert General
Solid into Plate/Wall command.

BIM toolbox .
EES’ Convert
-;1 General solid into beam/column
= General solid into plate/wall

=1 Part of a general solid to a member
= gl Beam/slab into general solid
BT Align

3& Evaluate - Clash check

2o | |

If conversion isn’t desired, the entities can remain as general solid or reference geometry and support
conditions (nodal, line, surface, etc.) can be added.

The final model in SCIA Engineer after the transfer from Autodesk Revit is shown below.




Import changes & results to Autodesk Revit

Now that the project has been loaded, analyzed and designed the modified geometry and results can be
sent back to Autodesk Revit for documentation and coordination.

Import .r2s file into Autodesk Revit

1.
2.
3.

6.

Open SCIA Engineer file, SCIA-Revit Transfer_Results. This file already has loading and results.
Navigate to File > Export > Revit file to create new .r2s file.

In order to import analysis results, users must install the Structural Analysis Toolkit 2015 that is
available for Autodesk Revit. The toolkit can be downloaded for free from the following link:

https://apps.exchange.autodesk.com/RVT/en/Detail/Index?id=appstore.exchange.autodesk.com%3Astr
ucturalanalysistoolkit2015 windows64%3Aen

Review &

With a new project open, access the CADS tab and select Review and Import  impert ™ in order to import
the file that was exported from SCIA Engineer. Make sure that the link options are set up to accept new
analysis results.

Open Autodesk Revit and start a new project.

4 Import
Analysis results Yes
|pdate 20 Member Openings No

Once the file has been imported, select the 3D Analytical Model View.

Access Structural Analysis results in Revit

1.

14

B % a

Robot , Analyze Results Results
Structural Analysis  in Cloud Manager Explorer | g

Next, the Structural Analysis functionality can be
accessed from the Analyze tab.

Select the button for Results Explorer
import the analysis results from
SCIA Engineer to Revit.

Results

Explorer Structural Analysis

With the results imported, open up the 3D View > Analytical Model, select a load case and result type
and then click Apply.

The structural analysis toolkit will now show the forces, moments or deformations on the 3D model.

Results for Analytical Model | Scia-Revit Transfe.. | 2%

Model. Scia-Revit Transfer_v15 - >
B
Analysis Analysis Resuls = =

Load Case: 2] ] -

Resut

=1 [~ Results for members
[ Forces
# [ Moments
[ Displacements

=1 [V Resuits for sufaces

(" Membrane forces Moo
" Membrane forces Ny
€ Membrane forces Moy
(" Shearforces Choc
" Shearforces Qyy
Momert:
(& Moments Mhoc &)
" Moments Myy ]
~ Moments My %]
= [ Defomation
[T Local coordinate system for members
[ Local coordinate system for surfaces
[Z] Global coordinate system
Comr [ o [ )]

Ready



https://apps.exchange.autodesk.com/RVT/en/Detail/Index?id=appstore.exchange.autodesk.com%3Astructuralanalysistoolkit2015_windows64%3Aen
https://apps.exchange.autodesk.com/RVT/en/Detail/Index?id=appstore.exchange.autodesk.com%3Astructuralanalysistoolkit2015_windows64%3Aen

10.

It is also possible to export internal forces on beams as reaction “tags” to be used to document the

beam end reactions.

Navigate to the View tab and add Structural Plan View for Level 7.

Navigate to the Annotate tab and select the button for Beam Annotations

Beam
notations

In the Beam Annotations dialog add the Structural Framing Tags for the Start & End Reaction Tags

Beam Annotations

Select the annotation type and location. A schematic preview is given below,

Placement

@) Al beams in current plan view
All selected beams in current plan view
[T Indude beams from links
|| Remove existing beam tags and spot elevations

@ Beams that have existing host file annotations will not be reannotated.

Annotation location and type

Level beams in plan | Sloped beams in plan

Use this tool to place beam annotations, tags and spot elevations, on the beams in your current plan view.

Beam annotations can be placed at the ends and mid-points of level and sloped beams. They can also be placed on either side of the beam.

Start Reaction Tag E]

Structural Framing Tag : Sta E]

End Reaction Tag E]

N

OK

] [ Cancel

Clicking OK will add the Beam End Reactions to
the beams in the plan view.

The maximum beam reactions that are shown on
the plane view of the structure coincide with the
maximum shear value (Vz) at either end from all of
the available combinations. For additional
information on analysis results and beam
reactions, refer to the CADS Revit Link Help guide
installed in Revit.
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