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General Information 
 

Welcome 
 

Welcome to the Scia Engineer Tutorial Shell. Scia Engineer is a design program under Windows with a broad application field: 
from checking simple frames to the advanced design of complex projects in steel, concrete, timber,... 

 

The program treats the calculation of 2D/3D frameworks, profile check and check of connections for steel structures included. 
Besides frames, it is also possible to dimension plate structures, inclusive of advanced concrete calculations. 

 

The complete process of calculation and design has been integrated in one program: input of the geometry, input of the 
calculation model (loads, supports, ...), linear and non-linear calculation, output of results, member check and optimization 
according to various codes, generating the calculation note, …  

 

Scia Engineer is available in three different editions: 

 

License version  

The license version of Scia Engineer is secured with a ‘dongle’, a code lock, which you apply to the parallel or USB gate of your 
computer or a softwarematic license on your network. 

Scia Engineer is modular and consists of various modules. The user chooses from the available modules and composes a 
custom design program, perfectly tuned to his needs. 

In the general product overview of Scia Engineer you will find an overview of the different modules that are available. 

 

Demo version  

If the program doesn’t find a protection, it will automatically start the demo version. The properties of the demo version are: 

All projects can be inserted; 

The calculation is restricted to projects with 25 elements, 3 plates/shells and two load cases; 

The output contains a watermark “Unlicensed software”; 

The projects that are stored in the demo version cannot be opened in a license version. 

 

Student version  

The student version has the same possibilities as the license version for all modules. This version is also secured by a ‘dongle’ 
or a softwarematic protection. 

The output contains a watermark “Student version”. 

Projects that are stored in the student version cannot be opened in the license version. 

 

Scia Engineer Support 
You can contact the Scia Engineer support service 

 

By e-mail 

Send an e-mail to support@Scia.be with a description of the problem and the concerning *.esa file, and mention the number 
of the version you are currently working with. 

By telephone 

 From Belgium :  +32 13 350310 

From the Netherlands :  +31 26 3201230 

Via the Scia Support website 

http://www.Scia-online.com/en/online-support.html 
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Website 
Link to Tutorials  

http://www.Scia-online.com > Support & Downloads > Free Downloads > input e-mail address > Scia Engineer > Scia 
Engineer Manuals & Tutorials 

Link to eLearning 

 http://www.Scia-online.com > Support & Downloads > eLearning 

Link to Demo version 

http://www.Scia-online.com > Support & Downloads > Secured Downloads > input username and password > Service Packs 
> Scia Engineer > Setup – Scia Engineer 

Start writing on an odd page. 

End each chapter using Insert > Section break – next page and type the new chapter name to the odd-page heading. Keep 
separate headings for each section. 

 

 

 

 

 

 



 

Project management 
 

Save, Save as, Close and open 
 

Before entering the construction, we first discuss how to save a project, how to open an existing project and how to close a 
project. When running a project of this Tutorial, the project can be saved at any time. That way you can leave the program at any 
time and resume the project from there afterwards. 

 

Saving a project 

Click on   in the toolbar. 

 

If a project has not yet been saved, the dialog box Save as  appears. Click on the arrow in the list Save to choose the drive you 
want to save your project in. Select the file in which you want to put the project and click on [Open ]. Select the subfolders. Enter 
the file name in File name  and click on [Save] to save the project. 

If you press  twice, the project is automatically stored with the same name. If you choose File > Save as  in the main 
menu, you can enter a new/other drive, folder and name for the project file.  

 

Closing a project 

 

To close a project, choose File > Close  in the main menu. 

 

A dialog box appears asking if you want to save the project. Depending on your choice, the project is saved and the active dialog 
is closed. 

 

Opening a project 

Click on   to open an existing project. 

 

A list with projects appears. Select the desired project and click [OK]  (or double-click on the project to open it). 
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Introduction 
 

Example of this Tutorial can be designed with the Licensed or Student versions. 

Before you proceed, you must be familiar with your operating system: for instance working with dialogues, menu bars, toolbars, 
status bars, handling the mouse, etc. Basic knowledge of input and editing of the structure in Scia Engineer is needed too. You 
should know how to input beams and slabs, loads and usage of the property window in Scia Engineer. 

This Tutorial describes the procedure how to parameterize Scia Engineer projects and make parametric user blocks usable 
directly in Scia Engineer  or in Scia ODA user-environment. 

 

First, we will explain how to parameterize continuous beam including loads and how to use this parametric user block. Second 
sample project is focused to a structure including slabs. 

 

Parametric project templates 
 

The program Scia Engineer is based on templates. It defines more types of templates: 

 

• document templates: a list of tables and pictures included to the document 
 

• document table templates: for each type of the table in the document can be defined 
 

• one or more templates for further usage in other documents and projects, 
 

• document page style templates 
 

• print templates 
 

• project templates: whole project including settings of design codes, 
 

• parametric project templates: enhancement of standard project templates by parameters. 

 

Requirements for parametric templates 
 

If the user wants to create parametric templates or user blocks then he or she has to buy module ESA.11 Parametric 
Modelling. 

Then there will be an item called “Parameters” in the Project data dialogue on the tab Functionality. This functionality must be 
switched on if we want to parameterize the structure.  

It is possible to load the non-parametric structure (standard Scia Engineer project) and add parameters later. 

 

             



 

 

Storage place of project templates 
 

All user defined project templates are stored in special folders. They can define one or more folders on local or network hard-
drives. It allows sharing of project templates among more users in a company. 

             

 

Using of project templates 
 

Standard and parametric project templates can be used in Scia Engineer or in Scia ODA user environment: 

• Scia Engineer allows to input, edit and analyze structures created on basis of the template. 
 

• Scia ODA user environment is designed for inputting of parametric project templates and analyzing those templates. 
It means that general editing of a model is not allowed. On the other hand templates designed for Scia ODA must 
define document and/or pictures in the picture gallery. 

 

 

This tutorial is focused on Scia Engineer. 

 

1. Run Scia Engineer 
  

2. Select New project from Scia Engineer File menu, the standard New project dialogue is displayed 
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3. If some project templates are stored in corresponding folder(s) the User templates tab appears. Switch to this tab. 
 

4. Select folder Sample Projects 
 

 
 

5. Select a template and press button <OK> 
 

6. Template dialogue with parameters is displayed 
 

7. Fill in parameters and press button <OK> 
 

8. A standard project based on the selected template is created. The user can edit the project by the Template dialogue  
(in the Main menu ) or by standard Scia Engineer functions. 

 

 



 

Example #1: 3-span beam 
 

The goal of this sample project is to create a project template for parametric input of a three span concrete beam loaded by self 
weight and standard permanent load. The project template can be use for easy input of parameterized structure directly in Scia 
Engineer or in Scia ODA user environment. 

 

Definition of the structure 
 

1. Create a simple 3 span concrete beam by standard Scia Engineer functions in a Frame XY . For parametric input, it is 
much easier to place the first node in the origin of coordinate system. For the purpose of this Tutorial, the material 
quality and cross-section used are not important. The geometry is shown in the picture below. 
 

 
 

2. The next step is to define loads in 3 load cases: 
 

• LC 1: self weight – all beams are automatically loaded by self weight 
 

• LC 2: permanent, standard load: line and point load on 1st and 3rd spans. The line load has a value of -4kN/m. The 
point loads have a value of -7kN and are placed relatively on the outside beams respectively on 30% and 70%. 
 

• LC 3: permanent, standard load: line and point load on 2nd span. The line load has a value of -3kN/m. The point 
load has value of -7kN and is placed in the middle of the middle beam. 

 

LC2: 

                 
LC3: 
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Definition of parameters 
 

We can continue by defining the required parameters. The Parameter Menu  can be accessed by clicking on Main Menu ���� 
Tools ���� Parameters  in Tree window . 

 

Geometry: 

Name Type Description Evaluation Formula Value 

length_1 length Length of 1st span value  4 m 

length_2 length Length of 2nd span value  6 m 

length_3 length Length of 3rd span value  4 m 

pos_2 length position of 2nd span formula length_1+length_2  

pos_3 length position of 3rd span formula pos_2+length_3  

 

Cross-section: 

Name Type Description Evaluation Value 

width_1 css length width of 1st cross-section value 500 mm 

width_2 css length width of 2nd  cross-section value 500 mm 

width_3 css length width of 3rd  cross-section value 500 mm 

heigth_1 height height of 1st cross-section value 500 mm 

height_2 height height of 1st cross-section value 500 mm 

height_3 height height of 1st cross-section value 500 mm 

 

Loads: 

Name Type Description Evaluation Value 

l_load_1 line load line load on 1st span value -4 kN/m 

l_load_2 line load line load on 2nd span value -3 kN/m 

l_load_3 line load line load on 3rd span value -4 kN/m 

f_load_1 force force load on outer beam value -7 kN 

f_load_2 force force load on inner beam value -7 kN 

f_pos_1 relative position of force on outer beams value 0.3 

f_pos_2 relative position of force on inner beam value 0.5 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

                
 

Note: Formula type parameters are calculated from other parameters and are for internal use 

(they are not usable in parametric input dialog). For example in this case formulas are used 

for definition of end node position of second and third beams. 

 

 

After defining all necessary parameters, click <CLOSE>. 

 

Scia Engineer now checks the correctness of the use formulas. Click <YES>. 
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Assigning parameters to the structure 
 

1. Select the end node of the first span 
 
 

 
2. Select item GCS coordinates > Coord X [m]  in the Property window . If appropriate parameters are defined then the 

edit box is replaced by a combo box. This means, you can now input not only a real value, but also a defined 
parameter. 
 

3. Change the value to "length_1 " parameter (using the little down-arrow button). 
 
 

   
 
 

4. Change the X co-ordinates of end nodes for the second and third span in the same way (node N3 and N4). 
 

5. Change their values to "pos_2" and "pos_3" respectively. 
 

        
 

6. The next step is to assign parameters to loads. 
 
• Adjust the second load case to be displayed in the window. 
 
• Select the first load and let’s focus on the Property window again. 
 

 
 



 

 
• Change the load value to parameter "l_load_1". 

 

     
 
• Adjust value of the forces and other line load one by one similarly. 

 

7. Do the same change with the load in the last load case. 

 

 

Template dialogue 
 

The user can define a template dialogue for easier editing of input parameters. Defined 

parameters can be arranged to sets (represented by tabs in the dialogue) and to groups 

(represented by trees). 

 

1. Open the Parameter template settings in the Tools menu . Let’s define three parameter sets according to the pictures 
below. 
 

2. Select parameters in the Available parameters  window and move them to the Selected parameters  window by pressing 
Add selected  button. 
 

• First tab: 
 

 
 
Click <OK> to save this set. 
 
Click <NEW> to add a second list (see below). 
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• Second tab: 
 

 
 

 

• Third tab: 
 

                         
 

 

3. The Parameter set  window gives the 3 parameter sets: Beams, Cross section and Loads  

 

 

 

 



 

 

 

 

                     
 

4. The next step is to prepare a picture to accompany the first set. 
• Close the manager and adjust 
• Set a standard “View Y” view in the graphical window. 
• Use function File > Print picture > Save picture to file to save the drawing into an external BMP file. 

 

Note: In this case we made just one picture to accompany with all three sets. Character of the structure is rather longitudinal so 
all three pictures in one will better fit window. 

 

5. Alternatively pictures may be easily composed in Picture gallery (see User’s guide for further information), and/or imported 
from any external picture editor. 

 

6. Open the Parameter sets manager   (Tools > Parameters template settings ) and edit  the Geometry set (or Loads set or 
Cross section set). 
 

7. Assign the picture to the tab using button [Picture ]. 
 

8. At this moment the project is prepared to be saved as parameterized template.  
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Saving the project as a template 
 

All Scia Engineer  projects can be used as templates. When the user wants to use a standard or parameterized project as a 
template then he has to copy it to a folder which is defined in the Options  dialogue on the tab Directories (Setup > Options > 
Directories ): 

1. Save the project to standard Engineer file to a standard folder defined for Engineer files 
 

     
 

2. Copy the project to the folder defined for User Templates . 



 

 
3. Restart Scia Engineer  

 
4. Alternatively it is possible to save the file directly to the folder defined for User Templates . 

 

Creating of a new project based on the parametric P roject template  
 

Using of parametric templates is very easy. 

 

1. Open a new project: 
 

• Call function File > New , 
 

• select a tab User templates , 
 

 
 

• select a project, 
 

• press OK button. 
 

2. Go through individual tabs and fill in the parameters 
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Once the parameters have been defined (notice that only few numbers had to be inserted), the project is opened and a new 3-
span continuous beam is automatically created in front of you. 

 

The project template can pre-define also document, pictures in the picture gallery and in the paper space gallery and default 
values for design on members. 

 

Editing of a parametric project 

If the template dialogue for the parametric project is created then a user can edit parameters by it. It means that all parameters 
are kept in the project and they are not replaced by actual values. This feature brings possibility to edit parameters by the 
template dialogue anytime. 



 

Example #2: L-shaped slab 
The goal of this sample project is to create project template for parametric input of L-shaped slab. The slab is loaded by self 
weight and surface load. Also the surface load is parameterized. 

Storing, opening and editing of the parametric template is the same as in the 1st example. 

 

Definition of the structure 
 

1. Create a simple L shaped slab. Coordinates of the nodal points are shown in the picture below. 

 

               
 

Note: As in the previous example we place the first node to the origin of coordinate system. 

 

2. Define loads in 4 load cases: 

 

• LC 1: self weight 
 

• LC 2: variable, standard 
 

• LC 3: variable, standard 
 

• LC 4: variable, standard 
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LC 2: 

 

        
LC 3: 

 

                   
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

LC 4: 

 

       
 

Definition of parameters 
 

Define parameters: use function Tools -> Parameters  in the Main menu:  

 

Geometry parameters: 

Name Type Description Evaluation Formula Value 

x_len_1 length  X Length of 1st span value  4 m 

x_len_2 length X Length of 2nd  span value  4 m 

y_len_1 length Y Length of 1st span value  4 m 

y_len_2 length Y Length of 2nd span value  4 m 

x_pos_2 length X end position of 2nd span formula x_len_1 + x_len_2  

y_pos_2 length Y end position of 2nd span formula y_len_1 + y_len_2  

thick_1 css length thickness of 1st slab value  200 mm 

thick_2 css length thickness of 2nd slab value  200 mm 

thick_3 css length thickness of 3rd slab value  200 mm 

 

Loads:  

Name Type Description Evaluation Formula Value 

load_1 surface load  surface load on 1st slab value  -5 kN/m² 

load_2 surface load  surface load on 2nd slab value  -5 kN/m² 

load_3 surface load  surface load on 3rd slab value  -5 kN/m² 

 

 

 

 

 

 

 

 



Tutorial Parametric Input 

 

         
 

 

 

 

Assigning parameters to the structure  
 

1. Select nodes which have the same X coordinates 
 

 
 

2. Select item GCS coordinates > Coord X [m]  and change its content to x_len_1 , in the Property window  (using the little 
down-arrow button) 

        
 



 

3. Change the X co-ordinates of nodes on the right side of the picture for coordinate x_pos2  
 

4. Do the same changes for Y direction and use parameters y_len_1  and y_pos2  
 

5. Adjust the second load case to be displayed in the window. Select the surface load and change the load value to parameter 
load_1  
 

 
 
 

         
 
 

6. Make the same changes with the load in the next load cases 

 

 

Template dialogue 
 

The user can define a template dialogue for easier editing of input parameters. Defined parameters can be arranged to sets 
(represented by tabs in the dialogue) and to groups (represented by trees). 

1. Open the Parameter set manager (Main menu > Tools > Parameters template settings ). Let’s define three parameter 
sets according to the pictures below. 
 

2. Select parameters in the Available parameters  window and move them to the Selected parameters  window by pressing 
the Add selected  button. 
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• First set: 
 

 
 

• Second set: 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

• Third set: 
 

 
 
 

3. The next step is to prepare a picture to accompany the first set. 
 

• Close the Parameter template settings  
 

• Set a standard AXO view in the graphical window 
 

• Use function File > Print picture > Save picture to file  to save the drawing into an external BMP file 
 

• Alternatively pictures can be easily composed in Picture gallery (see User’s guide for further information), 
and/or imported from any external picture editor. 
 

4. Open the Parameter template settings 
 

5. Select the Geometry 
 

6. Assign the picture to the tab using button [Picture ] 
7.  

                            
 

At this moment the project is prepared to be saved as parameterized template 


